
#1    <<YourApp>> Help Index

How To ...
<<add your application-specific "how to" topics here>>

Commands
File menu
Edit menu
View menu
Window menu 
Help menu

1# main_index



#2K3 $4 File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Document Setup Selects a printer and printer connection.
Print Prints a document.
Print Preview Displays the document on the screen as it would appear 

printed.
Quit Quits <<YourApp>>.

2# menu_file
3K files: managing
4$ File menu commands



#5Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.

5# menu_edit



#6View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

#7Window menu commands

The Window menu offers the following commands, which enable you to arrange 
multiple views of multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Window 1, 
2, ...

Goes to specified window.

6# menu_view
7# menu_window



#8Help menu commands

The Help menu offers the following commands, which provide you assistance with 
this application: 

About Baloon Help Displays information about Baloon help.
Show/Hide Baloon Help  Turns Baloon help on or off.

8# menu_help



#9K10 $11 New command (File menu)

Use this command to create a new document in <<YourApp>>.    Select the type of 
new file you want to create in the File New dialog box.    << Remove previous 
sentence if your application supports only one document type. >>

You can open an existing document with the Open command.

Shortcuts
Toolbar: {bmc filenew.bmp}
Keys: {bmc maccmd.bmp}+N

9# HID_FILE_NEW
10K files: managing
11$ File New command



#12File New dialog box

<< Delete this help topic if your application supports only one document type. >>

Specify the type of document you wish to create:
<< List your application's document types here >>

12# AFX_HIDD_NEWTYPEDLG



#13K14 $15 Open command (File menu)

Use this command to open an existing document in a new window.    You can open 
multiple documents at once.    Use the Window menu to switch among the multiple 
open documents.    See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts
Toolbar: {bmc fileopen.bmp}
Keys: {bmc maccmd.bmp}+O

13# HID_FILE_OPEN
14K files: managing
15$ File Open command



#16File Open dialog box

The following options allow you to specify which file to open:
Drives or Desktop

Select the drive, in which <<YourApp>> stores the file that you want to open, or 
Desktop. 

File Name
Select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
<< List your application's file types here. >>

16# AFX_HIDD_FILEOPEN



#17K18 $19 Close command (File menu)

Use this command to close all windows containing the active document.    
<<YourApp>> suggests that you save changes to your document before you close it.
If you close a document without saving, you lose all changes made since the last time
you saved it.    Before closing an untitled document, <<YourApp>> displays the Save 
As dialog box and suggests that you name and save the document.

Shortcuts
Keys: {bmc maccmd.bmp}+W
Mouse:Double-click the Close box.

17# HID_FILE_CLOSE
18K files: managing
19$ File Close command



#20K21 $22 Save command (File menu)

Use this command to save the active document to its current name and folder. When 
you save a document for the first time, <<YourApp>> displays the Save As dialog 
box so you can name your document.    If you want to change the name and folder of 
an existing document before you save it, choose the Save As command.

Shortcuts
Toolbar: {bmc filesave.bmp}
Keys: {bmc maccmd.bmp}+S

20# HID_FILE_SAVE
21K files: managing
22$ File Save command



#23K24 $25 Save As command (File menu)

Use this command to save and name the active document.    <<YourApp>> displays 
the Save As dialog box so you can name your document.    

To save a document with its existing name and folder, use the Save command.

23# HID_FILE_SAVE_AS
24K files: managing
25$ File Save As command



#26File Save As dialog box

The following options allow you to specify the name and location of the file you're 
about to save:
Save document as

Type a new filename to save a document with a different name.    

Folders
Select the existing folder in which you want to store the document, or select New 
for a new folder.

<< Add other File Save As dialog box options depending on which ones your 
application chooses via the OFN_ flags of the OPENFILENAME structure used by the 
CFileDialog. >>

26# AFX_HIDD_FILESAVE



#27 K28 $29 1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last 
four documents you closed.    Choose the number that corresponds with the 
document you want to open.

27# HID_FILE_MRU_FILE1
28K files: managing
29$ File 1, 2, 3, 4 command



#30K31 $32 Quit command (File menu)

Use this command to end your <<YourApp>> session.    <<YourApp>> prompts you 
to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Close box.
Keys: {bmc maccmd.bmp}+Q

30# HID_APP_EXIT
31K exit
32$ File Exit command



#33Undo/Can't Undo command (Edit menu)

<< Your application's user interface for Undo may differ from the one described 
below.    Modify this help text accordingly. >>

Use this command to reverse the last editing action, if possible. The name of the 
command changes, depending on what the last action was.    The Undo command 
changes to Can't Undo on the menu if you cannot reverse your last action.

Shortcut
Keys: {bmc maccmd.bmp}+Z 

33# HID_EDIT_UNDO



#34Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put 
it on the clipboard.    This command is unavailable if there is no data currently 
selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar: {bmc editcut.bmp}
Keys: {bmc maccmd.bmp}+X

34# HID_EDIT_CUT



#35Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is 
unavailable if there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar: {bmc editcopy.bmp}
Keys: {bmc maccmd.bmp}+C

35# HID_EDIT_COPY



#36Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    
This command is unavailable if the clipboard is empty.

Shortcuts
Toolbar: {bmc editpast.bmp}
Keys: {bmc maccmd.bmp}+V

36# HID_EDIT_PASTE



#37K38 $39 Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some 
of the most common commands in <<YourApp>>, such as File Open.    A check mark 
appears next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.

37# HID_VIEW_TOOLBAR
38K toolbar
39$ View Toolbar command



#40K41 $42 Toolbar
{bml hlptbar.bmp}

The toolbar is displayed across the top of the application window, below the menu 
bar.    The toolbar provides quick mouse access to many tools used in <<YourApp>>,

<< Add or remove toolbar buttons from the list below according to which ones your 
application offers. >>

Click To
{bmc filenew.bmp} Open a new document.

{bmc fileopen.bmp} Open an existing document.    <<YourApp>> displays the Open 
dialog box, in which you can locate and open the desired file.

{bmc filesave.bmp} Save the active document or template with its current name.    If
you have not named the document, <<YourApp>> displays the Save As 
dialog box.

{bmc editcut.bmp} Remove selected data from the document and stores it on the 
clipboard.

{bmc editcopy.bmp} Copy the selection to the clipboard.

{bmc editpast.bmp} Insert the contents of the clipboard at the insertion point.

{bmc fileprnt.bmp} Print the active document.

40# AFX_HIDW_TOOLBAR
41K toolbar
42$ toolbar



#43K44 $45Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to 
be executed by the selected menu item or depressed toolbar button, and keyboard 
latch state. A check mark appears next to the menu item when the Status Bar is 
displayed.

See Status Bar for help on using the status bar.

43# HID_VIEW_STATUS_BAR
44K status bar
45$ View Status Bar Command



#46K47 $48Status Bar
{bml hlpsbar.bmp}

The status bar is displayed at the bottom of the <<YourApp>> window.    To display 
or hide the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow 
keys to navigate through menus.    This area similarly shows messages that describe 
the actions of toolbar buttons as you depress them, before releasing them.    If after 
viewing the description of the toolbar button command you wish not to execute the 
command, then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched 
down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.

46# AFX_HIDW_STATUS_BAR
47K status bar
48$ status bar



#49New Window command (Window menu)

Use this command to open a new window with the same contents as the active 
window.    You can open multiple document windows to display different parts or views
of a document at the same time.    If you change the contents in one window, all other
windows containing the same document reflect those changes.    When you open a 
new window, it becomes the active window and is displayed on top of all other open 
windows.

49# HID_WINDOW_NEW



#50Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 

50# HID_WINDOW_CASCADE



#51Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.

51# HID_WINDOW_TILE



#521, 2, ... command (Window menu)

<<YourApp>> displays a list of currently open document windows at the bottom of 
the Window menu.    A check mark appears in front of the document name of the 
active window.    Choose a document from this list to make its window active.    

52# HID_WINDOW_ALL



#53About Baloon Help command (Help menu)

Use this command to display information about Baloon help.

53# HID_APP_ABOUT



#54 Show/Hide Baloons Command (Help Menu)

Use this command to turn Baloon help on or off.

54# HID_HELP_SHOW



#55$56Context Help command 
{bml curhelp.bmp}

Use the Context Help command to obtain help on some portion of <<YourApp>>.    
When you choose the Toolbar's Context Help button, the mouse pointer will change to
an arrow and question mark.    Then click somewhere in the <<YourApp>> window, 
such as another Toolbar button.    The Help topic will be shown for the item you 
clicked.

Shortcut
Keys: SHIFT+F1

55# HID_CONTEXT_HELP
56$ Help Using Help Command



#57Title Bar

<< Show your application's title bar here. >>

The title bar is located along the top of a window.    It contains the name of the application and 
document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their 
title bars.

A title bar may contain the following elements:
{bmc bullet.bmp} Zoom box
{bmc bullet.bmp} Name of the application
{bmc bullet.bmp} Name of the document

57# HID_HT_CAPTION



#58 Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes 
inside the scroll bars indicate your vertical and horizontal location in the document.    
You can use the mouse to scroll to other parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they 
behave in your application. >>

58# scrollbars



#59$60Ruler command (View menu)

<< Write application-specific help here. >>

59# HID_VIEW_RULER
60$ View Ruler Command



#61$62Choose Font dialog box

<< Write application-specific help here. >>

61# AFX_HIDD_FONT
62$ Choose Font Dialog



#63$64Choose Color dialog box

<< Write application-specific help here. >>

63# AFX_HIDD_COLOR
64$ Choose Color Dialog



#65$66Find command (Edit menu)

<< Write application-specific help here. >>

65# HID_EDIT_FIND
66$ Edit Find Command



#67$68Find dialog box

<< Write application-specific help here. >>

67# AFX_HIDD_FIND
68$ Find Dialog



#69$70Replace command (Edit menu)

<< Write application-specific help here. >>

69# HID_EDIT_REPLACE
70$ Edit Replace Command



#71$72Replace dialog box

<< Write application-specific help here. >>

71# AFX_HIDD_REPLACE
72$ Replace Dialog



#73$74Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat 
menu item changes to Can't Repeat if you cannot repeat your last action.

Shortcut
Key: F4

73# HID_EDIT_REPEAT
74$ Edit Repeat Command



#75$76Clear command (Edit menu)

<< Write application-specific help here. >>

75# HID_EDIT_CLEAR
76$ Edit Clear Command



#77$78Clear All command (Edit menu)

<< Write application-specific help here. >>

77# HID_EDIT_CLEAR_ALL
78$ Edit Clear All



#79$80Next Pane

<< Write application-specific help here. >>

79# HID_NEXT_PANE
80$ Next Pane Command



#81$82Prev Pane

<< Write application-specific help here. >>

81# HID_PREV_PANE
82$ Prev Pane Command



#83Modifying the Document

<< Write application-specific help here that provides an overview of how the user 
should modify a document using your application.    

If your application supports multiple document types and you want to have a distinct 
help topic for each, then use the help context i.d. generated by running the 
MAKEHELP.BAT file produced by AppWizard.    Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, 
then the help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic
for the first document type supported by your application.    AppWizard produces an 
alias in the .HPJ file for your application, mapping HIDR_DOC1TYPE to the HIDR_ 
produced by MAKEHM for that document type. >>

83# HIDR_DOC1TYPE



#84No Help Available

No help is available for this area of the window.

84# HID_HT_NOWHERE



#85 No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for 
each AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help 
topic for the Invalid Filename message box. >>

85# AFX_HIDP_default


